Home > redmine db > redmine db migrate error

Redmine Db Migrate Error

about 8 years ago Hello All, I'm trying to setup Redmine on a Windows 2003 Enterprise edition. I have installed ruby186-26, redmine-0.7.3 redmine migration and I have rails-2.0.2. I have my database MYSQL 6 upgrade redmine 2 to 3 up and running. To give a brief idea I have executed the following commands: ran, svn co latest redmine version http://redmine.rubyforge.org/svn/trunk redminethen ran, copy database.yml.example database.ymlcreated a database using roots credentials, create database redmine character set utf8; and then I tried running, rake db:migrate Rails_ENV="production" . But bitnami redmine upgrade it gave me an error saying that rake is not recognized as an internal or external command. By the way when I ran the rake command I was in my C:\redmine-0.7.3> location. Can someone please help me with this. I'm sure I'm doing something silly here. Please let me know as I have done a

Migrate Redmine To New Server

lot of research by myself and have failed to solve this issue. Thanks Replies (5) RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Thomas Lecavelier about 8 years ago Hi Tony, Since you install every thing from packages, you just haven't rake... So, time to install it: http://rake.rubyforge.org/ (personnaly, I prefer working with the gem app manager, which handle dependancies) RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Tony Sanders about 8 years ago Thank you for you responsding.I installed the rake using the "gem install --remote rake" and it ran just fine.But, when I try to execute , C:\redmine-0.7.3>rake db:migrate Rails_ENV="production", it doesn't work.Have no idea what am I missing on. Any help would be appreciated. Thanks RE: Getting error when running the rake db:migrate Rails_ENV="production" - Added by Tony Sanders about 8 years ago Here's the screenshot of the error. error.doc (56.5 KB) RE: Getting error when running the rake db:migrate Rail

I am trying to run the command RAILS_ENV=production rake db:migrate through SSH but I get an error of rake aborted! syntax error on line 8, col 10:

Redmine Database Location

` encoding: utf8' I am running Ruby 1.8.7 and Rails 2.3.5, I redmine ruby version did have Ruby 1.8.4 but upgraded to 1.8.7 so I'm not sure if I need to start the redmine backup plugin whole installation process all over again or that won't be needed. Any help would be appreciated! Replies (5) RE: Problems Running: RAILS_ENV=production rake db:migrate - Added by John Smith over http://www.redmine.org/boards/1/topics/2098 6 years ago In case anyone has this problem in the future, after many hours I realized my password had a ; in it which was causing the problem. RE: Problems Running: RAILS_ENV=production rake db:migrate - Added by Felix Schäfer over 6 years ago I think you'd need to put the password in double quotes " " in the database.yml file. http://www.redmine.org/boards/2/topics/15892 RE: Problems Running: RAILS_ENV=production rake db:migrate - Added by Amil Waduwawara over 6 years ago +1 We're using Redmine 0.9.2 with following plugins with a MySQL back-end: Redmine Issues Group v0.1.7 (by Andrew Chaika) Timesheet v0.5.0 (by Eric Davis) I tried an upgrade with our existing database, but it gave so many (MySQL) failures during database upgrade (rake db:migrate RAILS_ENV=production). After so many hours searching on the Internet and chatting on IRC, Marco123 on IRC informed about a script on http://www.redmine.org/boards/3/topics/4701#message-14933. I tried it and database upgrade was successful. This is extracted from my comment on Redmine Wiki as Eric Davis suggested after correcting some mistakes. RE: Problems Running: RAILS_ENV=production rake db:migrate - Added by Andrew Perry over 4 years ago Complex passwords with symbols tend to cause problems, so definitely suggest quoting " " the password. RE: Problems Running: RAILS_ENV=production rake db:migrate - Added by Volkan Evrin over 4 years ago The solution is easy :-), you should leave a space between the password tag and your password in config/database.yml file. (1-5/5) Loading... Powered by Redmine © 2006-2014 Jean-Philippe Lang

Guys, Trying to install redmine and trying to prevent myself from having to use the "root" login when I access the database. With redmine db that in mine I created a "redmine" @ "localhost" user in mysql, a "redmine" database, gave user "redmine" r/w privileges to the "redmine" datbase and set up my config/database.yml redmine db migrate file as follows. production: adapter: mysql database: redmine host: localhost username: redmine password: y1Uv0X9x encoding: utf8 However, when I run "rake db:migrate RAILS_ENV="production" I get the following error with the following trace: joseph@Chopper:~/redmine-0.8$ rake db:migrate RAILS_ENV="production" --trace (in /home/joseph/redmine-0.8) ** Invoke db:migrate (first_time) ** Invoke environment (first_time) ** Execute environment ** Execute db:migrate rake aborted! Access denied for user 'redmine'@'localhost' (using password: YES) /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/mysql_adapter.rb:527:in `real_connect' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/mysql_adapter.rb:527:in `connect' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/mysql_adapter.rb:186:in `initialize' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/mysql_adapter.rb:85:in `new' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/mysql_adapter.rb:85:in `mysql_connection' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:292:in `send' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:292:in `connection=' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:260:in `retrieve_connection' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:78:in `connection' /usr/lib/ruby/gems/1.8/gems/activerecord-2.1.2/lib/active_record/migration.rb:408:in `initialize' /usr/lib/ruby/gems/1.8

Related content

No related pages.