Home > redmine 500 > redmine 500 error nomethoderror

Redmine 500 Error Nomethoderror

4 years ago Hello, I am running Redmine 2.0.3 stable :Environment: Redmine version 2.0.3.stable Ruby version 1.8.7 (amd64-freebsd9) Rails version 3.2.6 Environment production Database adapter MySQLRedmine plugins: no plugin installed I'm testing redmine out, so I've created a test project with a dummy task in it, and see how redmine is displaying it.But when I'm trying to access Gantt tab, I'm encountering a "500 - Internal error" : Started GET "/projects/newconsole/issues/gantt" for 10.0.2.142 at Fri Aug 24 12:37:45 +0000 2012Processing by GanttsController#show as HTML Parameters: {"project_id"=>"newconsole"}Completed 500 Internal Server Error in 13ms NoMethodError (undefined method `-' for true:TrueClass): lib/redmine/helpers/gantt.rb:69:in `initialize' app/controllers/gantts_controller.rb:34:in `new' app/controllers/gantts_controller.rb:34:in `show' The same exact error for Calendar tab.Other tabs and functionnalities are working fine... Is someone has an idea on how to fix this ? Thanks, -- Léo L. Replies (33) RE: Strange "NoMethodError" and "500 - Internal error" when accessing Gantt tab - Added by Leo L about 4 years ago Hi again, I read this problem often comes from using plugins... but I have none.I tested ChiliProject (a fork from redmine) to see how it behaves, and both Gantt/Calendar were displaying without problems.But I prefer to use redmine :-) It seems like a redmine problem only, but the logs aren't helping me at all...And I've now no clue about what can I try to fix this ! Any help would be appreciated. -- Léo L. RE: Strange "NoMethodError" and "500 - Internal error" when accessing Gantt tab - Added by Etienne Massip about 4 years ago Looking at the code there is no reason this error triggers :| Maybe you could try to upgrade the ruby interpreter used? RE: Strange "NoMethodError" and "500 - Internal error" when accessing Gantt tab - Added by Leo L about 4 years ago Hi Etienne, Thanks for your reply, even if I'm worried that the code didn't help :)You mean using ruby19 instead of ruby18 ? If so, I already tested it : Same problem... RE: Strange "NoMeth

5 years ago Redmine 1.1.0Debian 6, Apache, Passenger When I click on the Redmine Files tab I get a 500 error. http://www.redmine.org/boards/2/topics/32856 In the production.log I see a undefined method error. Does anyone have any tips on how to try to solve this undefined method error? NoMethodError (undefined method `find_project_by_project_id' for #): http://www.redmine.org/boards/2/topics/24387 passenger (3.0.0) lib/phusion_passenger/rack/request_handler.rb:96:in `process_request' passenger (3.0.0) lib/phusion_passenger/abstract_request_handler.rb:513:in `accept_and_process_next_request' passenger (3.0.0) lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:321:in `start_request_handler' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `send' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `handle_spawn_application' passenger (3.0.0) lib/phusion_passenger/utils.rb:479:in `safe_fork' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:270:in `handle_spawn_application' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:in `__send__' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously' passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:180:in `start' passenger (3.0.0) lib/phusion_passenger/classic_rails/application_spawner.rb:149:in `start' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:219:in `spawn_rails_application' passenger (3.0.0) lib/phusion_passenger/abstract_server_collection.rb:132:in `lookup_or_add' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:214:in `spawn_rails_application' passenger (3.0.0) lib/phusion_passenger/abstract_server_collection.rb:82:in `synchronize' passenger (3.0.0) lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:213:in `spawn_rails_application' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:132:in `spawn_application' passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application' passenger (3.0.0

current redmine version 3.1.0 on a new server. Than I've imported a database backup of an old http://www.redmine.org/boards/2/topics/48156?r=49603 redmine version (1.3.0) and performed an upgrade (migration).After adjusting some configuration files, everything seems to work. Our users can login and create new tickets and so on. Only the information page in the administration area generates an internal error. The htdocs\log\production.log contains the following entries. ----------------------------------------------------------------------------------Started GET "/redmine/admin/info" for 127.0.0.1 at 2015-08-28 15:21:52 +0200Processing redmine 500 by AdminController#info as HTML Current user: Wolle (id=3)Completed 500 Internal Server Error in 6ms (ActiveRecord: 2.0ms) NoMethodError (undefined method `authenticate' for nil:NilClass): app/models/user.rb:307:in `check_password?' app/models/user.rb:462:in `default_admin_account_changed?' app/controllers/admin_controller.rb:77:in `info' lib/redmine/sudo_mode.rb:63:in `sudo_mode'---------------------------------------------------------------------------------- The Server OS is Windows 2008 R2 and it is an internal Server for our intranet.I have no idea what I should do. Please redmine 500 error can anyone help me? Replies (3) RE: Error viewing the admin/info page - Added by Aleksander Stukov 9 months ago Hi Wolfgang,I'm facing problems like you describe on my own Redmine installation. Did you find a solution for it?. I'm really stuck, I'll really appreciate any tip. Best regards, RE: Error viewing the admin/info page - Added by Wolfgang Ketterer 9 months ago Hi Aleksander, yes, I found a solution and thanks god, a made some notes for myself. In my case the information page worked directly after the installation of Redmine. The problem did only occur after importing/migrating the data from my old instance backup. The reason in my case was the data in the table "users". Or more precisely, the record with the ID=1, Login=redmine. At that time I had a backup of the database directly after the installation of redmine (Backup1) and a again one after importing/migrating my old data (Backup2). To solve the problem, I de

Related content

redmine 500 error log
Redmine Error Log p errors in a redmine install It started trying to archive a project but now users can't even log in anymore Only the first admin user can login My production log tells me no errors bash- tail apps redmine log production log lockfile lib lockfile rb in new' lockfile lib lockfile rb in Lockfile' vendor plugins redmine-gitosis app models gitosis observer rb in update repositories' vendor plugins redmine-gitosis app models gitosis observer rb in after save' opt redmine ruby lib ruby observer rb in notify observers' opt redmine ruby lib ruby observer rb in each' opt redmine

redmine 500 error repository
Redmine Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the working and

redmine 500 internal server error repository
Redmine Internal Server Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the

redmine 500 error debug
Redmine Error Debug p ago I'm using -stable from svn I've configured everything as outlined in the installation guide Everything runs beautifully when started in WEBrick Running in Apache however yields a error that appears to be echo'd by Redmine not Apache's default I'm using Ruby Enterprise Edition on Ubuntu Here's my setup Ruby version i -linux RubyGems version Rails version Active Record version Action Pack version Active Resource version Action Mailer version Active Support version Application root usr share redmine redmine- Environment production Database adapter mysql Database schema version Here is the production log output FAILSAFE Tue Jan -

redmine 500 error login
Redmine Error Login p production log messages here http pastebin com Br sdGGk It only seems to happen when I login I have recently run a security update on Apache Ubuntu updated Any ideas EDIT I should mention I triedrake tmp cache clearrake tmp sessions clear and restarted Apache I'm using Passenger but this did not help Replies RE Error When Trying to Login - Added by Ron Adams over years ago It seems to be resolved now but I didn't really do anything other than another reload of Apache to fix an unrelated problem RE Error When Trying to

redmine 500 error issues
Redmine Error Issues p some of my project issues when clicked show me a internal error Looking at the logs I see this messages app views issues action menu html erb Rendered issues action menu html erb ms Rendered issues show html erb within layouts base ms Completed Internal Server Error in ms ActionView Template Error Mysql Error Column 'lft' in order clause is ambiguous SELECT issues id AS t r issues tracker id AS t r issues project id AS t r issues subject AS t r issues description AS t r issues due date AS t r issues

redmine 500 error after install
Redmine Error After Install p Ruby Gem Rails and then Redmine on my Redhat Linux Enterprise server I'm struggling to get redmine to run correctly I posted in another thread and received advice recommending the installation of mongrel which I tried If I clear cookies in my browser and load the page the initial page displays perfectly Clicking on any page returns the error if I clear my cookies I can view the inital page again but the pattern repeats I can view any page and then clicking a link returns another error Thanks in advance for any help Here's

redmine 500 error new issue
Redmine Error New Issue p Translation patches Defect Error when create a new issue in V Added by Mr DTTH almost years ago Updated almost years ago Status ClosedStart date Priority NormalDue date Assignee - Done Category IssuesTarget version - Resolution Invalid Affected version Description When I create a new issue it throw error Rails Redmine Started POST projects myos issues for at - - Processing by IssuesController create as HTML Parameters utf authenticity token ehVu qmPlS H PLVh ZRJ i kq k y OSJxxlLYsw issue tracker id subject Task Title description Content for task status id priority id assigned

redmine 500 internal server error svn
Redmine Internal Server Error Svn p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the