Home > redmine 500 > redmine 500 error login

Redmine 500 Error Login

production.log messages here: http://pastebin.com/Br3sdGGk It only seems to happen when I login. I have recently run a security update on Apache (Ubuntu 10.04, updated 3/2/2012). Any ideas? EDIT: I should mention I triedrake tmp:cache:clearrake tmp:sessions:clear and restarted Apache (I'm using Passenger) but this did not help. Replies (12) RE: 500 Error When Trying to Login - Added by Ron Adams over 4 years ago It seems to be resolved now, but I didn't really do anything, other than another reload of Apache to fix an unrelated problem... RE: 500 Error When Trying to Login - Added by Vladimir Tisma over 4 years ago Same thing here (Ubuntu 10.04/Apache/Passenger). However, I'm trying to never update anything in order not to break a dependency. I tried rebooting the computer, but it didn't help.Restarting Apache ONLY did help though.Thanksv. RE: 500 Error When Trying to Login - Added by rage vietnow over 4 years ago Same error here. Ubuntu 10.04/Apache/Passengerhttp://pastebin.com/Z5j6xqhn I restarted apache and it still didn't work but after restarting it again it works now. Don't know what changed. RE: 500 Error When Trying to Login - Added by Lucas B over 4 years ago This happened to me also, it took 2 restarts of Apache to get it going again. I'm not sure what caused it or what fixed it for that matter. RE: 500 Error When Trying to Login - Added by Daniel Kulesz over 4 years ago I have the same problem, also with Ubuntu 10.04.4 LTS and Apache2/Passenger. I tried restarting Apache2 several times, and also tried the deleting the tmp:cache and tmp:sessions, but nothing got better so far. Is there no reliable way how to solve this problem? :( RE: 500 Error When Trying to Login - Added by Vladimir Tisma over 4 years ago Update: it appears that ubuntu update to ruby 1.8.7 somehow broke redmine. I can't tell which version it was before, but since ubuntu has no downgrade either, I've tried 1.8.6 with rvm, and it fails randomly again. Tried 1.9.2 as well - no luck. It appears that rvm can't compile 1.8.2 and 1.8.3 (I understood there was a major difference between these), so I'm trying 1.8.5 now. RE: 500 Error When Trying to Login - Added by Vladimir Tisma over 4 years ago I still have no clue, but here is what I did to mitigate the problem:Created redmine DB backup.Reverted to a machine snapshot (luckily it is a VM).Disabled network before booting the machine again (while VM is turned off).Uninstalled unattended upgrades package (sudo apt-get remove --purge unattended-upgrades) - it's responsible for automatic update that happened.Reenabled network (VM must be turned off in order to do that). What I've learned is that on a reverted sys

be able to help me get my instance of redmine up and running.I've installed the latest packaged release, and it is reachable on the intended subdomain. The problem is that I can't login using the admin:admin default credentials. I am redirected to a '500 internal error' The production.log file contains:* Processing AccountController#login (for 99.7.95.23 at 2011-06-27 11:17:40) [GET] Parameters: {"action"=>"login", "controller"=>"account"}Rendering template http://www.redmine.org/boards/2/topics/29317 within layouts/baseRendering account/loginCompleted in 81ms (View: 46, DB: 0) | 200 OK [http://www.freenetworkmovement.org/login] Processing AccountController#login (for 99.7.95.23 at 2011-06-27 11:17:44) [POST] Parameters: {"back_url"=>"http%3A%2F%2Fwww.freenetworkmovement.org%3A12003%2F", "action"=>"login", "authenticity_token"=>"u4LFEIkA+/X4WgU+GKNNPoEQ8SnJY7eCszPviI44SnE=", "username"=>"admin", "controller"=>"account", "password"=>"[FILTERED]", "login"=>"Login »"} NoMethodError (undefined method `destroy' for {}:Hash): app/controllers/application_controller.rb:89:in `logged_user=' app/controllers/account_controller.rb:203:in `successful_authentication' app/controllers/account_controller.rb:155:in `password_authentication' app/controllers/account_controller.rb:142:in `authenticate_user' app/controllers/account_controller.rb:30:in `login' Rendering /home/freenet2/rails_apps/redmine/public/500.html (500 Internal Server http://www.redmine.org/boards/2/topics/24868 Error) and the result of gem query --local is: abstract (1.0.0)actionmailer (3.0.9)actionpack (3.0.9)activemodel (3.0.9)activerecord (3.0.9)activeresource (3.0.9)activesupport (3.0.9)arel (2.0.10)builder (2.1.2)bundler (1.0.15)daemons (1.1.4)erubis (2.6.6)gem_plugin (0.2.3)i18n (0.5.0)mail (2.2.19)mime-types (1.16)polyglot (0.3.1)rack (1.2.3)rack-mount (0.6.14)rack-test (0.5.7)rails (3.0.9)railties (3.0.9)rake (0.9.2)rdoc (3.6.1)thor (0.14.6)treetop (1.4.9)tzinfo (0.3.28) Replies (3) RE: 500 error on first login - Added by Isaac Wilder over 5 years ago Maybe not a 500 error, sorry. The message displayed is: Internal error An error occurred on the page you were trying to access.If you continue to experience problems please contact your Redmine administrator for assistance. If you are the Redmine administrator, check your log files for details about the error. RE: 500 error on first login - Added by Etienne Massip over 5 years ago See #7857, #7688 and RedmineInstall. RE: 500 error on first login - Added by Isaac Wilder over 5 years ago thank you very much Etienne, the patches worked. take care,imw (1-3/3) L

problem: suddenly I can't login to my redmine instance anymore (or anyone else). I go to the login page enter my credentials and then I get: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please http://www.redmine.org/boards/2/topics/26951 contact the server administrator, xxx and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Apache/2.2.14 (Ubuntu) http://stackoverflow.com/questions/18839449/cant-login-to-redmine-after-install-internal-error-500 Server at xxx Port 443 I'm a bit out of ideas now. The log files, redmines and apaches, don't show anything sensible! Everything looks fine there even if I turn on highest debug levels... The only strange message is Giving :session_key redmine 500 to SessionStore is deprecated, please use :key instead. but this I got even when it worked all right. For users still logged in everything continues to work fine but once you logged out, you're out of luck. Does anyone have an idea where to look? Thanks,Carsten Replies (18) RE: Can't login suddenly - Added by Carsten Schurig about 5 years ago Ok, found it. I updated the server running redmine to subversion 1.7 and that's the problem... RE: Can't login suddenly - redmine 500 error Added by Mischa The Evil about 5 years ago Carsten Schurig wrote: Ok, found it. I updated the server running redmine to subversion 1.7 and that's the problem... Can you please explain more precise what issues are caused by your switch to Subversion 1.7? I don't see any correlation between the Subversion update and the fact that users can't login to Redmine suddenly without any info written to the logs about it. Redmine uses its own authentication system thus there shouldn't be any interference with 3rd party software... RE: Can't login suddenly - Added by Carsten Schurig about 5 years ago Actually I don't understand this as well. But it is the symptoms: updated the server running redmine to SVN 1.7 => fail after login page without a sensible error message reinstalled SVN 1.6 => redmine works again And SVN 1.7 did work ok on the server as server and as client. And it's not the authentication as it seems. Access to the mysql database seems not to be the problem. One thing that might happen: redmine checks for some versions on start. In lib/redmine/version.rb e.g. an existing .svn directory is accessed directly and parsed for the revision (which is not so good btw, as it is heavily dependent on WC format). But actually this code doesn't look as it could break fatally on WC format change, it would just return a wrong revision. So I suspect there is a svn command called somewher

here for a quick overview of the site Help Center Detailed answers to any questions you might have Meta Discuss the workings and policies of this site About Us Learn more about Stack Overflow the company Business Learn more about hiring developers or posting ads with us Stack Overflow Questions Jobs Documentation Tags Users Badges Ask Question x Dismiss Join the Stack Overflow Community Stack Overflow is a community of 6.3 million programmers, just like you, helping each other. Join them; it only takes a minute: Sign up Can't login to Redmine after install, Internal error 500 up vote 1 down vote favorite I have Debian GNU/Linux unstable (sid), Linux zoonman 2.6.32-308.8.2.el5.028stab101.1 #1 SMP Sun Jun 24 20:25:35 MSD 2012 x86_64 GNU/Linux mysql Ver 15.1 Distrib 5.5.32-MariaDB, for debian-linux-gnu (x86_64) using readline 5.1 redmine-2.3.2 ruby 1.9.3 Rails 3.2.13 # RAILS_ENV=production script/about Environment: Redmine version 2.3.2.stable Ruby version 1.9.3-p194 (2012-04-20) [x86_64-linux] Rails version 3.2.13 Environment production Database adapter Mysql2 Redmine plugins: no plugin installed # ruby script/rails server webrick -e production => Booting WEBrick => Rails 3.2.13 application starting in production on http://0.0.0.0:3000 => Call with -d to detach => Ctrl-C to shutdown server [2013-09-04 06:22:31] INFO WEBrick 1.3.1 [2013-09-04 06:22:31] INFO ruby 1.9.3 (2012-04-20) [x86_64-linux] [2013-09-04 06:22:31] INFO WEBrick::HTTPServer#start: pid=11329 port=3000 [... skipped...] Started POST "/login" for 1.2.3.4 at 2013-09-04 06:22:52 +0400 Processing by AccountController#login as HTML Parameters: {"utf8"=>"✓", "authenticity_token"=>"qXvGycxPPcjjfS3cNpO/gDw2h+OXGYF3pGkUmzoRk3M=", "back_url"=>"http://zoonman.com:3000/", "username"=>"admin", "password"=>"[FILTERED]", "login"=>"Login »"} Current user: anonymous Successful authentication for 'admin' from 1.2.3.4 at 2013-09-04 02:22:52 UTC Redirected to http://zoonman.com:3000/ Completed 302 Found in 42ms (ActiveRecord: 6.7ms) NoMethodError (undefined method `options' for {:user_id=>1, :ctime=>1378261372, :atime=>1378261372}:Hash): /usr/lib/ruby/vendor_ruby/rack/session/abstract/id.rb:329:in `commit_session' /usr/lib/ruby/vendor_ruby/rack/session/abstr

Related content

redmine 500 error log
Redmine Error Log p errors in a redmine install It started trying to archive a project but now users can't even log in anymore Only the first admin user can login My production log tells me no errors bash- tail apps redmine log production log lockfile lib lockfile rb in new' lockfile lib lockfile rb in Lockfile' vendor plugins redmine-gitosis app models gitosis observer rb in update repositories' vendor plugins redmine-gitosis app models gitosis observer rb in after save' opt redmine ruby lib ruby observer rb in notify observers' opt redmine ruby lib ruby observer rb in each' opt redmine

redmine 500 error repository
Redmine Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the working and

redmine 500 internal server error repository
Redmine Internal Server Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the

redmine 500 error debug
Redmine Error Debug p ago I'm using -stable from svn I've configured everything as outlined in the installation guide Everything runs beautifully when started in WEBrick Running in Apache however yields a error that appears to be echo'd by Redmine not Apache's default I'm using Ruby Enterprise Edition on Ubuntu Here's my setup Ruby version i -linux RubyGems version Rails version Active Record version Action Pack version Active Resource version Action Mailer version Active Support version Application root usr share redmine redmine- Environment production Database adapter mysql Database schema version Here is the production log output FAILSAFE Tue Jan -

redmine 500 error issues
Redmine Error Issues p some of my project issues when clicked show me a internal error Looking at the logs I see this messages app views issues action menu html erb Rendered issues action menu html erb ms Rendered issues show html erb within layouts base ms Completed Internal Server Error in ms ActionView Template Error Mysql Error Column 'lft' in order clause is ambiguous SELECT issues id AS t r issues tracker id AS t r issues project id AS t r issues subject AS t r issues description AS t r issues due date AS t r issues

redmine 500 error after install
Redmine Error After Install p Ruby Gem Rails and then Redmine on my Redhat Linux Enterprise server I'm struggling to get redmine to run correctly I posted in another thread and received advice recommending the installation of mongrel which I tried If I clear cookies in my browser and load the page the initial page displays perfectly Clicking on any page returns the error if I clear my cookies I can view the inital page again but the pattern repeats I can view any page and then clicking a link returns another error Thanks in advance for any help Here's

redmine 500 error new issue
Redmine Error New Issue p Translation patches Defect Error when create a new issue in V Added by Mr DTTH almost years ago Updated almost years ago Status ClosedStart date Priority NormalDue date Assignee - Done Category IssuesTarget version - Resolution Invalid Affected version Description When I create a new issue it throw error Rails Redmine Started POST projects myos issues for at - - Processing by IssuesController create as HTML Parameters utf authenticity token ehVu qmPlS H PLVh ZRJ i kq k y OSJxxlLYsw issue tracker id subject Task Title description Content for task status id priority id assigned

redmine 500 error nomethoderror
Redmine Error Nomethoderror p years ago Hello I am running Redmine stable Environment Redmine version stable Ruby version amd -freebsd Rails version Environment production Database adapter MySQLRedmine plugins no plugin installed I'm testing redmine out so I've created a test project with a dummy task in it and see how redmine is displaying it But when I'm trying to access Gantt tab I'm encountering a - Internal error Started GET projects newconsole issues gantt for at Fri Aug Processing by GanttsController show as HTML Parameters project id newconsole Completed Internal Server Error in ms NoMethodError undefined method -' for true

redmine 500 internal server error svn
Redmine Internal Server Error Svn p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the