Home > redmine 500 > redmine 500 error log

Redmine 500 Error Log

errors in a redmine install.. It started trying to archive a project, but now users can't even log in anymore. Only the first admin user can login.My production log tells me no errors: bash-3.2$ tail apps/redmine/log/production.log lockfile (1.4.3) lib/lockfile.rb:559:in `new' lockfile (1.4.3) lib/lockfile.rb:559:in `Lockfile' vendor/plugins/redmine-gitosis/app/models/gitosis_observer.rb:22:in `update_repositories' vendor/plugins/redmine-gitosis/app/models/gitosis_observer.rb:13:in `after_save' /opt/redmine/ruby/lib/ruby/1.8/observer.rb:185:in `notify_observers' /opt/redmine/ruby/lib/ruby/1.8/observer.rb:184:in `each' /opt/redmine/ruby/lib/ruby/1.8/observer.rb:184:in `notify_observers' app/controllers/users_controller.rb:105:in `edit' Rendering /opt/redmine/apps/redmine/public/500.html (500 Internal Server Error) Any tips on how to proceed?Thanks in advance! Replies (2) RE: Internal errors but no log... - Added by Felix Schäfer over 5 years ago The log is the end of an error trace, invoke tail -n 50 and post the whole trace here. RE: Internal errors but no log... - Added by Henjo Hoeksma over 5 years ago Hi Felix, thanks for your response. I just kickstarted a whole new installation. I was just testing out anyways, figured it wasn't worth the time. Good tip though, I will keep that in mind. I knew it were only the last ten lines, but figured the error would be at the end... ;-) Thanks again though! Henjo (1-2/2) Loading... Powered by Redmine © 2006-2014 Jean-Philippe Lang

Translation patches Defect #2177 redMine 500 error Added by sunsun sunsjun almost 8 years ago. Updated over 6 years ago. Status:ClosedStart date:2008-11-13Priority:NormalDue date:Assignee:-% Done:0%Category:-Target version:- Resolution:Invalid Affected version: Description redMine 500 error Internal errorAn http://www.redmine.org/boards/2/topics/21736 error occurred on the page you were trying to access.If you continue to experience problems please contact your redMine administrator for assistance. An error occurred on the page you were trying to access. If http://www.redmine.org/issues/2177 you continue to experience problems please contact your redMine administrator for assistance ActionView::TemplateError (undefined method `length' for #) on line #22 of repositories/_dir_list_content.rhtml: 19: <%= distance_of_time_in_words(entry.lastrev.time, Time.now) if entry.lastrev && entry.lastrev.time %> 20: <%=h(entry.lastrev.author.to_s.split('<').first) if entry.lastrev %> 21: <% changeset = @project.repository.changesets.find_by_revision(entry.lastrev.identifier) if entry.lastrev && entry.lastrev.identifier %> 22: <%=h truncate(changeset.comments, 50) unless changeset.nil? %> 23: 24: <% end %> vendor/rails/actionpack/lib/action_view/helpers/text_helper.rb:50:in `truncate' app/views/repositories/_dir_list_content.rhtml:22:in `_run_erb_47app47views47repositories47_dir_list_content46rhtml' app/views/repositories/_dir_list_content.rhtml:1:in `each' app/views/repositories/_dir_list_content.rhtml:1:in `_run_erb_47app47views47repositories47_dir_list_content46rhtml' vendor/rails/actionpack/lib/action_view/base.rb:637:in `send' vendor/rails/actionpack/lib/action_view/base.rb:637:in `compile_and_render_template' vendor/rails/actionpack/lib/action_view/base.rb:365:in `render_template' vendor/rails/actionpack/lib/action_view/base.rb:316:in `render_file' vendor/rails/actionpack/lib/action_view/base.rb:331:in `render' vendor/rails/actionpack/lib/action_view/partials.rb:120:in `render_partial' vendor/rails/actionpack/lib/action_view/base.rb:352:in `render' app/views/repositories/_dir_list.rhtml:13:in `_run_erb_47app47views47repositories47_dir_list46rhtml' vendor/rails/actionpack/lib/action_view/base.rb:637:in `send' vendor/rails/actionpack/lib/action_view/base.rb:637:in `compile_and_render_template' vendor/rails/actionpack/lib/action_view/base.rb:365:in `render_template' vendor/rails/actionpack/lib/action_view/base.rb:316:in `render_file' vendor/rails/actionpack/lib/action_view/base.rb:331:in `render' vendor/rails/actionpack/lib/action_view/partials.rb:120:in `render_partial' vendor/rails/actionpack/lib/acti

Start here for a quick overview of the site Help Center Detailed http://serverfault.com/questions/693627/redmine-500-internal-server-error-on-my-account-page answers to any questions you might have Meta Discuss the http://stackoverflow.com/questions/11810910/redmine-500-error-internal-error-an-error-occurred-on-viewing-issues-view-all-i workings and policies of this site About Us Learn more about Stack Overflow the company Business Learn more about hiring developers or posting ads with us Server Fault Questions Tags Users Badges Unanswered Ask Question _ Server Fault is a redmine 500 question and answer site for system and network administrators. Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the top Redmine 500 Internal Server Error on My account page redmine 500 error up vote 1 down vote favorite I used this method to install redmine I installed redmine in /opt/redmine, and i checked my log in /opt/redmine/current/log/production.log I recently upgraded from 2.5.2.stable.13345 to 2.5.3.stable.14266 My install info. Environment: Redmine version 2.5.3.stable.14266 Ruby version 2.0.0-p481 (2014-05-08) [x86_64-linux] Rails version 3.2.19 Environment production Database adapter Mysql2 SCM: Subversion 1.8.8 Git 1.9.1 Filesystem
Redmine plugins: redmine_agile 1.3.2 redmine_graphs 0.1.0 sidebar_hide 0.0.7 My tail of production.log Completed 500 Internal Server Error in 42.6ms ActionView::Template::Error (cannot load such file -- tzinfo/definitions/Europe/London): 1: <%= labelled_fields_for :pref, @user.pref do |pref_fields| > 2:

<= pref_fields.check_box :hide_mail >

3:

<= pref_fields.time_zone_select :time_zone, nil, :include_blank => true >

4:

<= pref_fields.select :comments_sorting,[[l(:label_chronological_order), 'asc'],[l(:label_reverse_chronological_order), 'desc']] >

5:

<= pref_fields.check_box :warn_on_leaving_unsaved >

6: < end %> lib/redmine/views/labelled_form_builder.rb:42:in `time_zone_select' app/views/users/_preferences.html.erb:3:in `block in app_views_users_preferences_html_erb__1218068006107140812_70264432515560' app/helpers/application_helper.rb:1050:in `labelled_fields_for' app/views/users/_preferences.html.erb:1:in `_app_views_users__preferences_html_erb__1218068006107140812_70264432515560' app/views/my/account.html.erb:43:in `block in app_views_my_account_html_erb_373455605642633520_70264429441020' app/helpers/application_helper.rb:1043:in `labelled_form_for' app/views/my/account.html.erb:9:in `_app_views_my_account_html_erb__373455605642633520_70264429441020' Everything seems to be working except for "My

here for a quick overview of the site Help Center Detailed answers to any questions you might have Meta Discuss the workings and policies of this site About Us Learn more about Stack Overflow the company Business Learn more about hiring developers or posting ads with us Stack Overflow Questions Jobs Documentation Tags Users Badges Ask Question x Dismiss Join the Stack Overflow Community Stack Overflow is a community of 6.3 million programmers, just like you, helping each other. Join them; it only takes a minute: Sign up Redmine 500 error -Internal error An error occurred on viewing Issues/View All issues up vote 1 down vote favorite I recently upgrade redmine 0.8 to 1.4.4 .but after up-gradation when i am going to access/view Issues Redmine 500 error -Internal error An error occurred . This is the Log file of redmine production - /usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:162:instart' /usr/lib/ruby/1.8/webrick/server.rb:162:in start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:95:instart' /usr/lib/ruby/1.8/webrick/server.rb:92:in each'
/usr/lib/ruby/1.8/webrick/server.rb:92:instart' /usr/lib/ruby/1.8/webrick/server.rb:23:in start'
/usr/lib/ruby/1.8/webrick/server.rb:82:instart' Rendering /home/www/support.dokeos.com/www/public/500.html (500 Internal Server Error) My setup: Ruby implementation and version: 1.8.7 Rails version: 2.3.5 Gem version : 1.3.7 Operating system: Debian 2.6.32-5-686 i686 Database used, and its version: mysql 5.1.61 Ruby-aware server used: Apache2 UPDATE: Error.log /log# tail -f domain.com.error.log [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1934): proxy: initialized single connection worker 1 in child 21737 for (localhost) [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1803): proxy: worker proxy:forward already initialized [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1818): proxy: grabbed scoreboard slot 1 in child 21736 for worker http://localhost:3000/ [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1837): proxy: worker http://localhost:3000/ already initialized [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1934): proxy: initialized single connection worker 1 in child 21736 for (localhost) [Sun Aug 05 14:16:27 2012] [debug] proxy_util.c(1803): proxy: worker proxy:forward already initialized [Sun Aug 05 14:16:45 2012] [debug] proxy_util.c(1818): proxy: grabbed scoreboard slot 1 in child 21738 for worker http://localhost:3000/ [Sun Aug 05 14:16:45 2012] [debug] proxy_util.c(1837): proxy: worker http://localhost:3000/ already in

Related content

redmine 500 error repository
Redmine Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the working and

redmine 500 internal server error repository
Redmine Internal Server Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the

redmine 500 error debug
Redmine Error Debug p ago I'm using -stable from svn I've configured everything as outlined in the installation guide Everything runs beautifully when started in WEBrick Running in Apache however yields a error that appears to be echo'd by Redmine not Apache's default I'm using Ruby Enterprise Edition on Ubuntu Here's my setup Ruby version i -linux RubyGems version Rails version Active Record version Action Pack version Active Resource version Action Mailer version Active Support version Application root usr share redmine redmine- Environment production Database adapter mysql Database schema version Here is the production log output FAILSAFE Tue Jan -

redmine 500 error login
Redmine Error Login p production log messages here http pastebin com Br sdGGk It only seems to happen when I login I have recently run a security update on Apache Ubuntu updated Any ideas EDIT I should mention I triedrake tmp cache clearrake tmp sessions clear and restarted Apache I'm using Passenger but this did not help Replies RE Error When Trying to Login - Added by Ron Adams over years ago It seems to be resolved now but I didn't really do anything other than another reload of Apache to fix an unrelated problem RE Error When Trying to

redmine 500 error issues
Redmine Error Issues p some of my project issues when clicked show me a internal error Looking at the logs I see this messages app views issues action menu html erb Rendered issues action menu html erb ms Rendered issues show html erb within layouts base ms Completed Internal Server Error in ms ActionView Template Error Mysql Error Column 'lft' in order clause is ambiguous SELECT issues id AS t r issues tracker id AS t r issues project id AS t r issues subject AS t r issues description AS t r issues due date AS t r issues

redmine 500 error after install
Redmine Error After Install p Ruby Gem Rails and then Redmine on my Redhat Linux Enterprise server I'm struggling to get redmine to run correctly I posted in another thread and received advice recommending the installation of mongrel which I tried If I clear cookies in my browser and load the page the initial page displays perfectly Clicking on any page returns the error if I clear my cookies I can view the inital page again but the pattern repeats I can view any page and then clicking a link returns another error Thanks in advance for any help Here's

redmine 500 error new issue
Redmine Error New Issue p Translation patches Defect Error when create a new issue in V Added by Mr DTTH almost years ago Updated almost years ago Status ClosedStart date Priority NormalDue date Assignee - Done Category IssuesTarget version - Resolution Invalid Affected version Description When I create a new issue it throw error Rails Redmine Started POST projects myos issues for at - - Processing by IssuesController create as HTML Parameters utf authenticity token ehVu qmPlS H PLVh ZRJ i kq k y OSJxxlLYsw issue tracker id subject Task Title description Content for task status id priority id assigned

redmine 500 error nomethoderror
Redmine Error Nomethoderror p years ago Hello I am running Redmine stable Environment Redmine version stable Ruby version amd -freebsd Rails version Environment production Database adapter MySQLRedmine plugins no plugin installed I'm testing redmine out so I've created a test project with a dummy task in it and see how redmine is displaying it But when I'm trying to access Gantt tab I'm encountering a - Internal error Started GET projects newconsole issues gantt for at Fri Aug Processing by GanttsController show as HTML Parameters project id newconsole Completed Internal Server Error in ms NoMethodError undefined method -' for true

redmine 500 internal server error svn
Redmine Internal Server Error Svn p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the