Home > redmine 500 > redmine 500 error debug

Redmine 500 Error Debug

ago I'm using 0.8-stable from svn. I've configured everything as outlined in the installation guide. Everything runs beautifully when started in WEBrick. Running in Apache, however, yields a 500 error that appears to be echo'd by Redmine, not Apache's default. I'm using Ruby Enterprise Edition on Ubuntu 8.04. Here's my setup: Ruby version 1.8.7 (i686-linux) RubyGems version 1.3.5 Rails version 2.1.2 Active Record version 2.1.2 Action Pack version 2.1.2 Active Resource version 2.1.2 Action Mailer version 2.1.2 Active Support version 2.1.2 Application root /usr/share/redmine/redmine-0.8 Environment production Database adapter mysql Database schema version 101 Here is the production.log output: /!\ FAILSAFE /!\ Tue Jan 12 14:22:02 -0500 2010 Status: 500 Internal Server Error No route matches "/index.html" with {:method=>:get} /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/routing/recognition_optimisation.rb:67:in `recognize_path' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/routing/route_set.rb:385:in `recognize' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:148:in `handle_request' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:107:in `dispatch' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:104:in `synchronize' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:104:in `dispatch' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:120:in `dispatch_cgi' /usr/local/lib/ruby/gems/1.8/gems/actionpack-2.1.2/lib/action_controller/dispatcher.rb:35:in `dispatch' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/railz/request_handler.rb:50:in `process_request' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/abstract_request_handler.rb:207:in `main_loop' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/railz/application_spawner.rb:378:in `start_request_handler' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/railz/application_spawner.rb:181:in `spawn_application!' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/utils.rb:183:in `safe_fork' /usr/local/lib/ruby/gems/1.8/gems/passenger-2.2.5/lib/phusion_passenger/railz/application_spawner.rb:15

Translation patches Defect #17351 500 Internal Server Error when deploying in Tomcat 7 Added by John H over 2 years ago. Updated over 2 years ago. Status:NewStart date:Priority:NormalDue date:Assignee:-% Done:0%Category:-Target version:- Resolution: Affected version: Description Hi all, So I have installed both Redmine-2.4.5 and Redmine-2.5.1 several times, with several combinations of Ruby/JRuby and Redmine version. I have been able to get nearly all combinations to successfully work in the webrick test server, however none of them work in tomcat 7. I followed all steps and have created http://www.redmine.org/boards/2/topics/10694?r=10697 successfully .war files for the redmine projects, however when added to the auto_deploy directory of tomcat, I always get a 500 error "Rack::ShowStatus" I have a topic up on the forums here if it can provide anymore help: http://www.redmine.org/boards/2/topics/42958 My Specs:OS: Win7Database: SQL Server 2008 R2Ruby: 1.9.3 (most current minor)Jruby: 1.6.8Tomcat: 7. Just to reitterate, the installations of Redmine have already http://www.redmine.org/issues/17351 tested successfully outside of Tomcat, as well as Tomcat has been tested and is working as well. 500error.png (7.4 KB) John H, 2014-06-30 23:14 500error2.png (14.4 KB) John H, 2014-07-01 00:01 History #1 Updated by John H over 2 years ago File 500error2.png added Attached is the end error I get, even though I have sqljdbc4.jar in the Tomcat7 lib directory.. I'm not sure where to go from this. #2 Updated by John H over 2 years ago Okay, so I got the damn thing to work after about 7 hours of debug. Still not sure if its going to be completely smooth, however just wanted to put my solution here: All I did was:Remove/Delete "sqljdbc.jar" from "Java_SDK/jre/lib/ext" -- as well as -- "tomcat/lib" directories, leaving only the sqljdbc4.jar. Apparently there is a pointing/dependency issue between sqljdbc and sqljdbc4 As mentioned, still not sure if I will run into any later issues, but feel relieved that at least I have a .war file that is deploying. Also available in: Atom PDF Loading... Powered by Redmine © 2006-2014 Jean-Philippe Lang

here for a quick overview of the site Help Center Detailed answers to any questions you might http://stackoverflow.com/questions/37276270/500-internal-server-error-when-accessing-http-redmineexample-com-my-page have Meta Discuss the workings and policies of this site About Us Learn more about Stack Overflow the company Business Learn more about hiring developers or posting ads with us Stack Overflow Questions Jobs Documentation Tags Users Badges Ask Question x Dismiss Join the Stack Overflow Community Stack Overflow is a community of 6.3 redmine 500 million programmers, just like you, helping each other. Join them; it only takes a minute: Sign up 500 Internal Server Error when accessing http://redmineexample.com/my/page up vote 1 down vote favorite After migration to new server users haves 500 error when accessing /my/page. Error: Started GET "/my/page" for 172.30.60.118 at 2016-05-17 14:03:31 +0200 Processing by MyController#page redmine 500 error as HTML Current user: krzysztof.golos (id=14) Rendered issues/_list_simple.html.erb (24.0ms) Rendered my/blocks/_issuesassignedtome.html.erb (109.1ms) Rendered issues/_list_simple.html.erb (27.5ms) Rendered my/blocks/_issuesreportedbyme.html.erb (39.2ms) Rendered my/blocks/_issueswatched.html.erb (7.2ms) Rendered my/page.html.erb within layouts/base (158.8ms) Completed 500 Internal Server Error in 169.6ms ActionView::Template::Error (no implicit conversion of nil into String): 1:

2: <%= link_to l(:label_watched_issues), 3: issues_path(:set_filter => 1, :watcher_id => 'me', :sort => 'updated_on:desc') %> 4: (<%= Issue.visible.watched_by(user.id).count %>) 5:

6: 7: <% watched_issues = issueswatched_items %> app/views/my/blocks/_issueswatched.html.erb:4:in `_app_views_my_blocks__issueswatched_html_erb___2499037382860342811_70277487537940' app/views/my/page.html.erb:29:in `block in _app_views_my_page_html_erb___2611345217716520421_70277481863500' app/views/my/page.html.erb:26:in `each' app/views/my/page.html.erb:26:in `_app_views_my_page_html_erb___2611345217716520421_70277481863500' New server: Redmine version 2.6.10.stable, Ruby version 2.3.1-p112 (2016-04-26)[x86_64-linux], Rails version 3.2.22.2 Old server: Redmine version 2.4.0.stable, Ruby version 1.9.3-p448 (2013-06-27) [x86_64-linux], Rails version 3.2.15 Anybody can help? ruby-on-rails ruby redmine share|improve this question asked May 17 at 12:30 Jakub Manikowski 61 look at your line 4. Issue.visible.watched_by(user.id).count You are having a nil value somewhere here. try to debug it and see if it helps –noman tayyab May 17 at 13:28 Yeah, put a pry in My

Related content

redmine 500 error log
Redmine Error Log p errors in a redmine install It started trying to archive a project but now users can't even log in anymore Only the first admin user can login My production log tells me no errors bash- tail apps redmine log production log lockfile lib lockfile rb in new' lockfile lib lockfile rb in Lockfile' vendor plugins redmine-gitosis app models gitosis observer rb in update repositories' vendor plugins redmine-gitosis app models gitosis observer rb in after save' opt redmine ruby lib ruby observer rb in notify observers' opt redmine ruby lib ruby observer rb in each' opt redmine

redmine 500 error repository
Redmine Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the working and

redmine 500 internal server error repository
Redmine Internal Server Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the

redmine 500 error login
Redmine Error Login p production log messages here http pastebin com Br sdGGk It only seems to happen when I login I have recently run a security update on Apache Ubuntu updated Any ideas EDIT I should mention I triedrake tmp cache clearrake tmp sessions clear and restarted Apache I'm using Passenger but this did not help Replies RE Error When Trying to Login - Added by Ron Adams over years ago It seems to be resolved now but I didn't really do anything other than another reload of Apache to fix an unrelated problem RE Error When Trying to

redmine 500 error issues
Redmine Error Issues p some of my project issues when clicked show me a internal error Looking at the logs I see this messages app views issues action menu html erb Rendered issues action menu html erb ms Rendered issues show html erb within layouts base ms Completed Internal Server Error in ms ActionView Template Error Mysql Error Column 'lft' in order clause is ambiguous SELECT issues id AS t r issues tracker id AS t r issues project id AS t r issues subject AS t r issues description AS t r issues due date AS t r issues

redmine 500 error after install
Redmine Error After Install p Ruby Gem Rails and then Redmine on my Redhat Linux Enterprise server I'm struggling to get redmine to run correctly I posted in another thread and received advice recommending the installation of mongrel which I tried If I clear cookies in my browser and load the page the initial page displays perfectly Clicking on any page returns the error if I clear my cookies I can view the inital page again but the pattern repeats I can view any page and then clicking a link returns another error Thanks in advance for any help Here's

redmine 500 error new issue
Redmine Error New Issue p Translation patches Defect Error when create a new issue in V Added by Mr DTTH almost years ago Updated almost years ago Status ClosedStart date Priority NormalDue date Assignee - Done Category IssuesTarget version - Resolution Invalid Affected version Description When I create a new issue it throw error Rails Redmine Started POST projects myos issues for at - - Processing by IssuesController create as HTML Parameters utf authenticity token ehVu qmPlS H PLVh ZRJ i kq k y OSJxxlLYsw issue tracker id subject Task Title description Content for task status id priority id assigned

redmine 500 error nomethoderror
Redmine Error Nomethoderror p years ago Hello I am running Redmine stable Environment Redmine version stable Ruby version amd -freebsd Rails version Environment production Database adapter MySQLRedmine plugins no plugin installed I'm testing redmine out so I've created a test project with a dummy task in it and see how redmine is displaying it But when I'm trying to access Gantt tab I'm encountering a - Internal error Started GET projects newconsole issues gantt for at Fri Aug Processing by GanttsController show as HTML Parameters project id newconsole Completed Internal Server Error in ms NoMethodError undefined method -' for true

redmine 500 internal server error svn
Redmine Internal Server Error Svn p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the