Home > redmine 500 > redmine 500 error after install

Redmine 500 Error After Install

Ruby, Gem, Rails, and then Redmine on my Redhat Linux Enterprise server. I'm struggling to get redmine to run correctly. I posted in another thread and received advice recommending the installation of mongrel, which I tried. If I clear cookies in my browser and load the page, the initial page displays perfectly. Clicking on any page returns the 500 error. if I clear my cookies, I can view the inital page again, but the pattern repeats: I can view any page and then clicking a link returns another 500 error. Thanks in advance for any help. Here's what Mongrel shows in response to the request: /!\ FAILSAFE /!\ Wed Jun 18 14:17:21 +0000 2008 Status: 500 Internal Server Error wrong number of arguments (2 for 1) /usr/lib/ruby/1.8/cgi/session.rb:267:in `respond_to?' /usr/lib/ruby/1.8/cgi/session.rb:267:in `initialize_without_cgi_reader' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/cgi_ext/session.rb:39:in `initialize' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/cgi_process.rb:130:in `new' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/cgi_process.rb:130:in `session' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/cgi_process.rb:166:in `stale_session_check!' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/cgi_process.rb:114:in `session' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:1131:in `assign_shortcuts_without_flash' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/flash.rb:167:in `assign_shortcuts' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:518:in `process_without_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/filters.rb:685:in `process_without_session_management_support' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/session_management.rb:123:in `process' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/base.rb:388:in `process' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:171:in `handle_request' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:115:in `dispatch' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher.rb:126:in `dispatch_cgi' /usr/lib/ruby/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/dispatcher

+ apache2 + Passenger it being error after i install backlogs plugin : Internal error An error occurred on the page http://www.redmine.org/boards/2/topics/1381 you were trying to access.If you continue to experience problems please contact your Redmine administrator for assistance. If you are the Redmine administrator, check your log files for details http://www.redmine.org/boards/2/topics/29537 about the error. The following was shown in the production.log : Processing WelcomeController#index (for 192.168.2.110 at 2012-03-14 19:13:23) [GET]Parameters: {"controller"=>"welcome", "action"=>"index"}Rendering template within layouts/baseRendering welcome/index ActionView::TemplateError (Unable to load settings) on line #20 of app/views/layouts/base.html.erb:17: body {behavior: url(<%= stylesheet_path "csshover.htc" >);}18: 19: 20: <= call_hook :view_layouts_base_html_head >21: 22: <= yield :header_tags -%>23:

vendor/plugins/redmine_backlogs/app/models/rb_task.rb:7:in `tracker'lib/redmine/hook.rb:63:in `send'lib/redmine/hook.rb:63:in `call_hook'lib/redmine/hook.rb:63:in `each'lib/redmine/hook.rb:63:in `call_hook'lib/redmine/hook.rb:60:in `tap'lib/redmine/hook.rb:60:in `call_hook'lib/redmine/hook.rb:144:in `call_hook'app/views/layouts/base.html.erb:20/usr/lib/ruby/vendor_ruby/action_view/renderable.rb:34:in `send'/usr/lib/ruby/vendor_ruby/action_view/renderable.rb:34:in `render'/usr/lib/ruby/vendor_ruby/action_view/base.rb:306:in `with_template'/usr/lib/ruby/vendor_ruby/action_view/renderable.rb:30:in `render'/usr/lib/ruby/vendor_ruby/action_view/template.rb:205:in `render_template'/usr/lib/ruby/vendor_ruby/action_view/base.rb:265:in `render'/usr/lib/ruby/vendor_ruby/action_view/base.rb:352:in `_render_with_layout'/usr/lib/ruby/vendor_ruby/action_view/base.rb:262:in `render'/usr/lib/ruby/vendor_ruby/action_controller/base.rb:1252:in `render_for_file'/usr/lib/ruby/vendor_ruby/action_controller/base.rb:936:in `render_without_benchmark'/usr/lib/ruby/vendor_ruby/action_controller/benchmarking.rb:51:in `render'/usr/lib/ruby/vendor_ruby/action_controller/benchmarking.rb:51:in `render'/usr/lib/ruby/vendor_ruby/action_controller/base.rb:1328:in `default_render'/usr/lib/ruby/vendor_ruby/action_controller/base.rb:1334:in `perform_action_without_filters'/usr/lib/ruby/vendor_ruby/action_controller/filters.rb:617:in `call_filters'/usr/lib/ruby/vendor_ruby/action_controller/filters.rb:638:in `run_before_filters'/usr/lib/ruby/vendor_ruby/action_controller/filters.rb:189:in `call'/usr/lib/ruby/vendor_ruby/action_controller/filters.rb:189:in `call'/usr/lib/ruby/vendor_ruby/action_controller/filters.rb:635:in `

had to move my redmine to another Server Both are Debian with Postgres as Databasefrom Jessie redmine 500 error to Wheezy from 9.4 to 9.1 After the installation I tried to acces the redmine,I can login with my old account and can see my old tickets/issue but I cannot look at /create a ticketThen I get Error 500 What should I do ? Loading... Powered by Redmine © 2006-2014 Jean-Philippe Lang

error) when I open the "127.0.0.1/redmine". How to fix this? Thanks! tomd 2012-12-03 06:51:03 UTC #2 Start manager-windows.exe in install directory and look at your services. All services must running, if not - start service or restart all services. Jigsong 2012-12-03 07:05:25 UTC #3 yes, all services are running when I try to open the redmine. I also try to restart all services and retry to open the "127.0.0.1/redmine", there still the 500 error. tomd 2012-12-03 07:13:16 UTC #4 If you have plugins in plugins directory - detele them and restart all services. Jigsong 2012-12-03 07:25:40 UTC #5 I install the BitNami-Redmine 2.1.4 in a clean windows and there is no plugin and plugin directroy at all. by the way, could you please read the following problem and I want to fix that problem and get all data. But I didn't know how to do that because the answer is not so detailed. Thanks! http://community.bitnami.com/questions/8432/service-temporarily-unavailable-bitnami-redmine-v203-1-thin_redmine-and-thin_redmine2-cant-start?page=1#8470 /8432 victor 2012-12-03 09:47:23 UTC #6 Please, could you try to restart the apache service from the manager tool? Jigsong 2012-12-03 10:12:37 UTC #7 There still have that error:Redmine 500 error. victor 2012-12-03 10:14:38 UTC #8 Could you try to access to the following url: http://localhost:3001/redmine This is where the thin services are serving the application. Could you access to Redmine through this URL? tomd 2012-12-03 10:23:04 UTC #9 What do you see when open 127.0.0.1 or localhost ? lingoosoft 2012-12-18 05:55:11 UTC #10 Install processing, select the "... default data configration" value to "English", it is OK. Chinese Language is Error. Hope to improvement. victor 2012-12-18 10:40:43 UTC #11 You are right. It will be fixed in our future releases. There is a workaround: Edit the \apps\redmine\htdocs\app\views\layouts\index.html.erb and remove the characters after "BitNami Red

Related content

redmine 500 error log
Redmine Error Log p errors in a redmine install It started trying to archive a project but now users can't even log in anymore Only the first admin user can login My production log tells me no errors bash- tail apps redmine log production log lockfile lib lockfile rb in new' lockfile lib lockfile rb in Lockfile' vendor plugins redmine-gitosis app models gitosis observer rb in update repositories' vendor plugins redmine-gitosis app models gitosis observer rb in after save' opt redmine ruby lib ruby observer rb in notify observers' opt redmine ruby lib ruby observer rb in each' opt redmine

redmine 500 error repository
Redmine Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the working and

redmine 500 internal server error repository
Redmine Internal Server Error Repository p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the

redmine 500 error debug
Redmine Error Debug p ago I'm using -stable from svn I've configured everything as outlined in the installation guide Everything runs beautifully when started in WEBrick Running in Apache however yields a error that appears to be echo'd by Redmine not Apache's default I'm using Ruby Enterprise Edition on Ubuntu Here's my setup Ruby version i -linux RubyGems version Rails version Active Record version Action Pack version Active Resource version Action Mailer version Active Support version Application root usr share redmine redmine- Environment production Database adapter mysql Database schema version Here is the production log output FAILSAFE Tue Jan -

redmine 500 error login
Redmine Error Login p production log messages here http pastebin com Br sdGGk It only seems to happen when I login I have recently run a security update on Apache Ubuntu updated Any ideas EDIT I should mention I triedrake tmp cache clearrake tmp sessions clear and restarted Apache I'm using Passenger but this did not help Replies RE Error When Trying to Login - Added by Ron Adams over years ago It seems to be resolved now but I didn't really do anything other than another reload of Apache to fix an unrelated problem RE Error When Trying to

redmine 500 error issues
Redmine Error Issues p some of my project issues when clicked show me a internal error Looking at the logs I see this messages app views issues action menu html erb Rendered issues action menu html erb ms Rendered issues show html erb within layouts base ms Completed Internal Server Error in ms ActionView Template Error Mysql Error Column 'lft' in order clause is ambiguous SELECT issues id AS t r issues tracker id AS t r issues project id AS t r issues subject AS t r issues description AS t r issues due date AS t r issues

redmine 500 error new issue
Redmine Error New Issue p Translation patches Defect Error when create a new issue in V Added by Mr DTTH almost years ago Updated almost years ago Status ClosedStart date Priority NormalDue date Assignee - Done Category IssuesTarget version - Resolution Invalid Affected version Description When I create a new issue it throw error Rails Redmine Started POST projects myos issues for at - - Processing by IssuesController create as HTML Parameters utf authenticity token ehVu qmPlS H PLVh ZRJ i kq k y OSJxxlLYsw issue tracker id subject Task Title description Content for task status id priority id assigned

redmine 500 error nomethoderror
Redmine Error Nomethoderror p years ago Hello I am running Redmine stable Environment Redmine version stable Ruby version amd -freebsd Rails version Environment production Database adapter MySQLRedmine plugins no plugin installed I'm testing redmine out so I've created a test project with a dummy task in it and see how redmine is displaying it But when I'm trying to access Gantt tab I'm encountering a - Internal error Started GET projects newconsole issues gantt for at Fri Aug Processing by GanttsController show as HTML Parameters project id newconsole Completed Internal Server Error in ms NoMethodError undefined method -' for true

redmine 500 internal server error svn
Redmine Internal Server Error Svn p Translation patches Defect Subversion Internal Server Error when browsing a repository Added by Anthony C over years ago Updated about years ago Status ReopenedStart date - - Priority NormalDue date Assignee - Done Category SCMTarget version - Resolution Affected version Description I've added a subversion repository to one of our projects When I go to the repository tab to browse the repository I get a Internal Server Error The production log contains no entry at all for the page access The strangest part is that another repository on another server works perfectly Both the